DPM 2012 SP1 – Inventory Button is missing

Today I had a strange problem.
I couldn’t see the Inventory Button on an DPM Server Console.

After checking the drives and the library I could say there is everything fine.
Nothing unusual behavior.

So I tried to find an information about possible troubleshooting tips but without a result or hint whats going on.
But I was sure there are PowerShell cmdlts which could be helpful to me.

First i tried to find out more about the Library.

Get-DPMLibrary [[-DPMServerName]

The result gave me a very long name for the HP Library and the name wasn’t fully readable.

[…] Library: Hew… […]

Taking this as library name wasn’t helpful and I got an error back.

Start-DPMLibraryInventory [-DPMLibrary] <Library> [-FastInventory]

The solution was to change the values a bit.

$DPMLib=Get-DPMLibrary -DPMServerName “ServerName”
Start-DPMLibraryInventory -DPMLibrary $DPMLib[0] -FastInventory

[0] is the library If you have several librarys you have to count and put the correct value in it.

Get-DPMLibrary

http://technet.microsoft.com/en-us/library/hh881783.aspx

Start-DPMLibraryInventory

http://technet.microsoft.com/en-us/library/hh881614.aspx

DPM 2012 SP1 Update Rollup 3–Issues

A couple of weeks ago the CU3 for DPM 2012 SP1 cracked something in the SQL Database of one of my DPM Servers.
The Microsoft Support scheduled my case very quickly and resolved the problem within half an hour.

Now after one week CU3 re-release it seems the situation is cleared and everything is fine.

 

Important Update on DPM 2012 SP1 Update Rollup 3–Issues and Workarounds (Update: UR3 has been re-released)